WordPress数据库导入错误

如果你的空间不理想或是需要升级服务器,这个时候很可能需要进行网站数据搬家,而数据搬家本身是一件很简单的事情。并且学建站网页专门有这样的课程教大家:WordPress网站安全&搬家视频教程,如果还不会搬家的朋友可以学习了解下。

然而最近有一个朋友遇到了一个小问题,在进行数据库搬迁的时候,出现了一个错误,无论怎么修改都不能解决,错误信息截图如下:

00000000001

这个提示不仅仅是数据库中的评论表问题,而是因为服务器的数据库版本差异导致的:
wordpress4.2版本之前的默认编码是utf8,而这个版本之后采用的是utf8mb4,因为编码的变更,所以导致如果你现在的数据库高低版本互导之间的错误,解决这个问题可以通过以下三个方法解决:

1、升级最新服务器的数据库版本(虚拟主机无权限);
2、分别修改数据库表的编码为utf8mb4,如果手动修改麻烦,可以通过以下sql语句方式修改:
ALTER TABLE 表名 CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;
※ 注意修改语句中表名为你不同的数据库表名。

3、导出数据库的时候选择“最大程度兼容数据库系统或旧版本的 MySQL 服务器”;

2016-11-24_105653

2016-11-24_105838

遇到问题一种方法不行就试下其他方法。

评论

微信扫描,手机学习

学建站网